Investigation - Message Latency

Incident Report for Mio

Resolved

This incident has been resolved.
Posted Dec 22, 2025 - 17:36 CST

Update

Mio has identified and resolved the issue that caused message latency from Google to Microsoft.

If you feel like you are still experiencing an issue, please submit a ticket to the help desk for our support engineers to investigate.

Thank you.
Posted Dec 22, 2025 - 15:23 CST

Investigating

Mio is currently investigating message latency being experienced by some organizations from Google Chat to Microsoft Teams. We've identified that this began within the last 2 hours(10:30am Eastern).

Mio will update this page over the next hour with further details.
Posted Dec 22, 2025 - 11:27 CST
This incident affected: API.