Message Latency

Incident Report for Mio

Monitoring

The messaging latency was caused by a degraded Microsoft endpoint for managing lifecycle subscriptions. Microsoft has fixed the endpoint, and message delivery has returned to normal latency. No action required on our side.
Posted Jul 27, 2026 - 09:51 CDT

Identified

We have identified the root cause of the issue causing elevated response times and delays across our messaging services for Microsoft users.

Core services remain operational, but message delivery may be delayed while these events fail to process as expected.

Our engineering team is actively working with Microsoft toward resolution. We will provide our next update as soon as new information becomes available.
Posted Jul 24, 2026 - 11:47 CDT

Investigating

Users are experiencing elevated message delivery latency on the messaging platform. Root cause is still under investigation.
Posted Jul 23, 2026 - 11:09 CDT
This incident affects: API.