Third Party Endpoint Causing Message Latency

Incident Report for Mio

Resolved

We have moved this to resolved, as we have seen the third party api be stable over the past few days. Mio will continue to monitor the impact of the degraded performance to make sure service is working as expected for all clients.
Posted Feb 19, 2026 - 11:49 CST

Monitoring

We are actively monitoring a Microsoft outage that occurred early on 2/17/2025 that is impacting Microsoft Teams. "Users may experience delays and failures when sending and receiving chat messages that include inline media (images, code snippets, videos)" - This incident can be tracked under the Microsoft ticket TM1233974 (admin.microsoft.com/#/MessageCenter/:/messages/TM1233974).
Posted Feb 17, 2026 - 13:52 CST

Investigating

Mio is currently investigating a third party end point that looks to be the root cause for message latency. We will provide more details once our investigation has completed.
Posted Feb 17, 2026 - 10:31 CST
This incident affected: API.