Message Latency from Microsoft Teams to Google Chat

Incident Report for Mio

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 10:04 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2026 - 10:26 CST

Investigating

Mio is currently investigating a potential service degradation related to Microsoft subscriptions endpoint.
Posted Feb 26, 2026 - 07:25 CST
This incident affected: Microsoft Endpoints.