Elevated Message Delivery Latency

Incident Report for Mio

Update

Following successful internal testing, we have deployed the first phase of our solution to address the underlying messaging infrastructure issues. Development fixes are now being rolled out across customer environments. We are closely monitoring system performance and throughput as these changes take effect, and we will provide a completion timeline in our next update.
Posted Jun 12, 2026 - 12:33 CDT

Update

Over the past week, we have seen a significant reduction in customer-reported impact related to message delivery latency. The infrastructure changes we implemented have stabilized throughput for the majority of affected users.

Our engineering team continues to work on a longer-term solution to fully address the underlying cause. We are in the process of validating these changes in our internal environment before broader deployment. We will provide a timeline for that deployment with our next update.
Posted Jun 03, 2026 - 11:48 CDT

Identified

We want to provide an update on Mio's current latency issues.

A subset of users continues to experience minimal message delivery latency across platforms. Messages are being delivered, but delays continue to occur, particularly during periods of elevated traffic.

Our engineering team has identified the root cause as instability in the underlying message queueing infrastructure. Under traffic spikes, the current system is not handling throughput at the level we require for consistent, reliable delivery.

We are implementing meaningful infrastructure changes, and it is actively underway. In parallel, we have deployed additional capacity to the existing system to reduce the impact while the migration is completed.

This incident will remain open until the migration is complete and performance has stabilized. If you are experiencing significant disruption, please reach out to our support team directly.

Thank you for your continued patience.
Posted May 28, 2026 - 13:48 CDT

Investigating

We are currently investigating intermittent message delivery latency affecting a subset of users across platforms. Messages are continuing to be delivered, but some may experience delays during periods of elevated traffic.

Our engineering team has identified instability within an underlying queueing component that is impacting throughput during traffic spikes. We are actively implementing infrastructure changes intended to improve long-term stability and resilience.

Because these changes involve core messaging infrastructure, this incident may remain open while work is completed and performance is closely monitored. In the meantime, the platform remains operational, and messages continue to process and deliver.

We will continue providing updates here as progress is made.

Thank you for your patience.
Posted May 22, 2026 - 11:30 CDT
This incident affects: API.